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1. Назначение и системные требования 

ПО SPTuner предназначено для онлайн- и оффлайн- редактирования настроечных данных 

SPTronic, просмотра данных диагностики, записи и просмотра осциллограмм работы 

двигателя. 

Для осуществления информационного обмена с ЭБУ используется адаптер SMS-Soft 

DiaLink. 

Запуск программы SPTuner возможен только при наличии USB-ключа защиты. Лицензия 

SPTuner может храниться:  

 в отдельном USB-ключе SPTuner (при при необходимости одновременного запуска 

ChipTuningPRO и SPTuner, ChipTuningPRO необходимо запускать в первую очередь); 

 в USB-ключе программы ChipTuningPRO (одновременный запуск ChipTuningPRO 

и SPTuner невозможен). 

Минимальные системные требования: 

 Intel Celeron 1000 MHz; 

 1 Gb RAM; 

 1 Gb HDD; 

 OC Windows XP SP2; 

 USB 1.1. 

2. Подготовка к работе 

ПО SPTuner передается пользователю в виде исполняемого дистрибутива с именем файла 

sptuner_setup_vN.MM.exe. (N.MM – версия программы) Для установки программы 

необходимо запустить данный файл и следовать указаниям программы установки.  

В процессе установки устанавливаются драйвер адаптера DiaLink и  драйвер электронного 

ключа защиты. Установка указанных драйверов не производится, если они уже имеются в 

системе и версия установленных драйверов не ниже, чем версия драйверов в 

дистрибутиве. 

Перед первым запуском SPTuner необходимо обновить микропрограмму адаптера 

DiaLink. Для этого необходимо скачать ПО SMSDiag3 на сайте www.sms-soft.ru, 

установить и запустить приложение SMSDiag3. После запуска обновление 

микропрограммы адаптера будет предложено автоматически. 

При использовании USB-ключа защиты от программы ChipTuningPRO в начале работы 

необходимо Установить последнюю версию ChipTuningPRO, запустить её и выполнить 

обновление микропрограммы ключа; 

Порядок активации лицензии: 

 Запустить программу SPTuner, появится сообщение об отсутствии 

микропрограммы SPTuner в ключе: 

  

http://www.almisoft.ru/
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 Нажать OK, после чего появится запрос на загрузку/обновление микропрограммы 

ключа: 

 

 

 

  

 Нажать OK, после чего начнется процесс загрузки микропрограммы ключа: 

  

 По окончанию процесса загрузки появится сообщение: 

 

 Нажать OK. Появится запрос на активацию функций микропрограммы SPTuner: 

 

 Текст из поля ввода ID необходимо отправить электронным письмом на адрес тех. 

поддержки SPTuner; 

 Полученный в ответном письме код активации необходимо ввести (вставить из 

буфера обмена) в поле Activation Code, нажать кнопку Activate. 

После запуска программа имеет следующий вид: 
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Перед первым подключением к ЭБУ необходимо выполнить настройку параметров 

соединения. Для этого необходимо в главном меню выбрать пункт 

Connection->Connection settings.... 

 

В появившемся окне отображается серийный номер USB-CAN адаптера DiaLink. 

Выпадающий список позволяет задать скорость обмена. По умолчанию в ЭБУ задана 

скорость 500 кБод. 

Для установки соединения необходимо выбрать пункт меню Connection->Connect. 

После установки соединения с ЭБУ статус подключения изменится на Online. 

Индикатор прогресса на главной панели состояния отображает степень завершенности 

процесса. В случае возникновения ошибок связи соединение разрывается, и выводится 

сообщение об ошибке. 

После установления соединения в заголовок окна SPTuner выводится наименование и 

версия прошивки ЭБУ. Внешний вид программы изменяется в соответствии с 

настройками рабочей области. Данные настройки хранятся в файлах с расширением STT. 

Если рабочая область не была настроена, или последний STT-файл был удален, то 

формируется пустая рабочая область (одна вкладка без окон).  

При первоначальной инсталляции SPTuner примеры файлов рабочей области создаются в 

директории Документы\SPTuner\workspaces. 

3. Описание интерфейса 

3.1. Рабочая область программы 

Рабочая область программы образуется набором вкладок и окон, содержащихся в каждой 

вкладке. При закрытии программы (закрытии файла параметров в offline-режиме) 

происходит автоматическая перезапись последнего STT-файла. 
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Для работы с файлами рабочей области предусмотрены пункты главного меню File: 

Open Workspace… 
Открытие файла рабочей области. При этом происходит 

автоматическое сохранение текущей рабочей области.  

Save Workspace As… 

Сохранение рабочей области под другим именем. При этом 

файл, из которого производилась загрузка рабочей области, 

модифицирован не будет. 

Close Workspace… 

Закрыть рабочую область. При этом происходит 

автоматическое сохранение текущей рабочей области и 

инициализация пустой рабочей области. 

Каждая вкладка может содержать следующие окна (в скобках указаны пункты меню для 

вызова): 

 Таблица параметров (Parameters); 

 Рабочий набор параметров (View->Workset); 

 Экспресс-панель (View->Express panel); 

 Окно диагностики (View->Diagnostic); 

 Осциллограф (View->Scope); 

 Окно характеристики (View->Characteristic); 

 Окно команд (View->Commands); 

 Окно стрелочного прибора (View->Circular Gauge). 

Если на текущей вкладке окно еще не было вызвано, то оно появляется в левом верхнем 

углу. При закрытии и последующем вызове окно появляется на том же месте. 

3.2. Таблица параметров 

Доступ к параметрам ЭБУ осуществляется с помощью таблицы (окна) параметров, 

вызываемой выбором пункта меню Parameters. 
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Кнопки панели инструментов окна параметров: 

 - добавить выбранные параметры в рабочий набор параметров; 

 - отрыть референтный файл параметров; 

 - сохранить значения параметров в файл; 

 - скопировать значения всех параметров из референтного файла в ОЗУ; 

 - сохранить значения всех параметров в ЭНП; 

 - включить фильтр наименований (номеров) параметров; 

 - восстановить значение выделенного параметра из ЭНП; 

 - включить режим отображения русских наименований в таблице; 

 - сравнение значений параметров со значениями из референтного файла. 

Для облегчения навигации и поиска параметров в левой части окна отображается дерево 

заголовков групп параметров. 

По щелчку на любой узел дерева в таблицу выводятся все параметры, входящие в данную 

группу. В колонке Value отображаются текущие (из ОЗУ) значения параметров. 

Корневой раздел параметров имеет наименование ALL PARS. 

Каждому типу параметра соответствует пиктограмма, отображаемая в столбце Num 

таблицы рядом с номером параметра. 

Параметры-переменные доступны только для просмотра. Параметры-настройки и 

параметры-характеристики доступны также для редактирования. Переход в режим 

редактирования осуществляется по двойному щелчку на строку в таблице, или нажатию 

клавиши Enter (если параметр выделен). 

При этом:  

 для простых параметров появится всплывающая строка ввода, для параметров-

селекторов появится выпадающий список с вариантами значений; 

 для параметров-характеристик или параметров-осей откроется дополнительное 

окно, позволяющее осуществить просмотр и редактирование значений. 

Новое значение параметра, редактируемого по месту, задается после нажатия клавиши 

Enter. В случае если введенное значение выходит за границы разрешенного диапазона 

параметра, оно будет ограничено. Для отмены ввода редактируемого значения 

необходимо нажать клавишу Esc, или выделить другой параметр в таблице. 

Использование фильтра позволяет значительно ускорить поиск нужного параметра, если 

известно его наименование или часть наименования. Например, на рисунке ниже показан 

результат использования фильтра по тексту "rpm". Для отмены фильтра необходимо 

очистить поле ввода или отжать кнопку . Поиск заданного текста производится только в 

активной группе. Для поиска по всем параметрам необходимо выделить корневой раздел 

ALL PARS. 
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Для открытия группы, к которой принадлежит выбранный параметр, необходимо в 

контекстном меню выбрать пункт Show topic. При этом будет отображен состав 

группы самого низкого уровня в иерархии, включающей данный параметр. 

Перенос значений всех параметров из ОЗУ во Flash производится нажатием на кнопку . 

В процессе переноса необходимо контролировать значение параметра Ver.Pars. При 

каждом успешном сохранении данных во Flash его значение увеличивается на 1.  

Если двигатель запущен, то перенос значений параметров во Flash невозможен. При этом 

формируется сообщение об ошибке. Для осуществления сохранения параметров после 

останова двигателя, питание ЭБУ не снимается, пока производится информационный 

обмен с ПК. 

Для сохранения текущих значений параметров в файл необходимо выбрать пункт 

главного меню File->Save parameters… щелкнуть по кнопке  и указать в диалоге 

путь и наименование файла. Файл параметров создается из данных, находящихся в ОЗУ 

ЭБУ. При этом флэш-память ЭБУ может содержать отличные значения. 

3.2.1. Загрузка референтного файла параметров 

Для удобства настройки (сравнение и импорт значений параметров) имеется возможность 

загрузки референтного файла параметров. Вывод диалога выбора файла осуществляется 

щелчком по кнопке . Загруженные значения для простых параметров выведутся в 

колонку File. Для просмотра и сравнения значений параметров-характеристик 

необходимо перейти в окно характеристики.  

Параметры, имеющие различные значения (кроме характеристик и осей) выделяются 

жирным шрифтом всегда. Для осуществления полного сравнения параметров необходимо 

нажать на кнопку . При этом сравниваются только значения параметров текущей 

группы. При переходе в другую группу результат сравнения теряется. 

Для переноса всех данных из файла в ОЗУ необходимо щелкнуть по кнопке .  
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Перенос значений только выделенных параметров осуществляется выбором пункта 

контекстного меню Copy data from file. 

 

 

 

3.3. Рабочий набор параметров 

Окно рабочего набора содержит таблицу и кнопки управления. Работа в этом окне 

осуществляется только в онлайн-режиме. Включение данного окна производится выбором 

пункта меню View->Workset. 

Добавление параметров в рабочий набор осуществляется перетаскиванием (Drag&Drop) из 

таблицы параметров. Тем самым создается набор параметров, требующих постоянного 

внимания. 

Работа с параметрами на данной панели производится аналогично таблице параметров 

(редактирование по месту или открытие окна характеристики), но имеются некоторые 

дополнительные возможности (подстройка значения колесом мыши). 

Для показа раздела выделенного параметра в окне параметров необходимо выбрать пункт 

Show topic контекстного меню. 

Рабочий набор параметров имеет следующие кнопки управления: 

 - удалить выбранный параметр из таблицы; 

 - восстановить значение параметра из ЭНП; 

 - включить режим подстройки значения параметра (используется колесо мыши); 

 - включить режим просмотра/редактирования битовых переменных. 
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3.4. Панель диагностики 

При наличии текущих диагностических сообщений о неисправности ЭСУД становится 

активным индикатор  на панели состояния. Для вызова панели диагностики 

необходимо щелкнуть по этому индикатору или выбрать пункт меню 

View->Diagnostic. Диагностические сообщения располагаются в таблице в 

произвольном порядке (сортировка определяется структурой ПО ЭБУ). 

Контекстное меню панели диагностики имеет пункты: 

 Show saved diagnostic – отображать сохраненную диагностику. При 

отсутствии галочки отображается текущая диагностика; 

 Copy to clipboard – скопировать содержимое таблицы в буфер обмена в 

текстовом виде; 

 Clear diagnostic – очистить диагностические сообщения. Производится 

независимо для текущей и сохраненной диагностики. Например, при просмотре 

текущей диагностики выбор данного пункта не приведет к очистке сохраненной 

диагностики. 

3.5. Панель команд 

Панель команд представляет собой отдельное окно с кнопками, состав которых 

определяется конфигурацией ЭБУ и может меняться для различных версий. Вызов панели 

производится выбором меню View->Commands. Описание назначения некоторых 

команд: 

Clear diags - сбросить диагностические сообщения; 

Power off - принудительно отключить питание после отключения зажигания. 

3.6. Редактирование параметров в оффлайн-режиме 

Для входа в оффлайн-режим необходимо в главном меню выбрать пункт  

File->Open parameters… После выбора файла параметров инициализируется 

рабочая область аналогично онлайн-режиму. Особенность данного режима в том, что 

параметры-переменные присутствуют в таблице, но отражают значения на момент 

сохранения файла в онлайн-режиме (значения из ЭБУ). Параметры-переменные 

отображаются серым цветом. 

При работе в оффлайн-режиме также имеется возможность загрузки референтного файла 

параметров. Все действия выполняются аналогично онлайн-режиму. 

Выход из оффлайн-режима производится выбором меню File->Close parameters. 

3.7. Просмотр и редактирование характеристик 

Вызов окна характеристики производится выбором пункта меню 

View->Characteristic или по двойному щелчку (или нажатию клавиши Enter) в 

таблице параметров или в рабочем наборе. 
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Кнопки панели инструментов окна характеристики: 

 - переход на предыдущую характеристику в истории просмотра; 

 - переход на следующую характеристику в истории просмотра; 

 - применить значения новых данных после редактирования (Ctrl+S); 

 - включить режим автоматического применения значений; 

 - обновить данные характеристики (считать из ЭБУ); 

 - автоматическое обновление данных с периодом 0,5 с; 

 - скопировать выделенный фрагмент в буфер обмена; 

 - вставить данные из буфера обмена; 

 - включить режим сечения для 3D-характеристик; 

 - горизонтальная линейная интерполяция; 

 - вертикальная линейная интерполяция; 

 - сглаживание выделенной области (b-сплайн); 

 - увеличить значения выделенных узлов; 

 - уменьшить значения выделенных узлов; 

 - умножить значения выделенных узлов; 

 - задать значения выделенных узлов. 
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Окно характеристики состоит из двух частей - таблицы значений и графической 

диаграммы, имеющей вид кусочно-линейной функции (для 2D-характеристик) или 

поверхности (для 3D-характеристик). В зависимости от настроек может отображаться 

либо таблица, либо диаграмма, либо одновременно обе части. 

Для перевода диаграммы в режим сечения необходимо нажать кнопку . При этом на 

диаграмме отображается кусочно-линейная функция, соответствующая выделенной 

строке в таблице значений. 

 

Редактирование данных осуществляется следующими способами: 

 Ввод значений в ячейках таблицы (вход в редактирование по двойному щелчку, 

нажатию Enter или любой цифровой клавиши); 

 Вставкой данных из буфера обмена (левый верхний угол вставки определяется 

позицией выделенной ячейки таблицы); 

 Групповое изменение значений для выделенных элементов. Используются кнопки 

 панели инструментов. Альтернативой использования кнопок  

является нажатие клавиш + и - на основной клавиатуре. Величина, на которую 

производится коррекция, вводится в поле на панели инструментов; 

 Изменение значений узлов диаграммы при помощи мыши (для 2D-характеристик и 

3D-характеристик в режиме сечения); 

 Применение вертикальной или горизонтальной линейной интерполяции для 

выделенных участков (кнопки ); 

 Сглаживание выделенных точек b-сплайном; 

 Импорт значений из CTE-файла. 

При редактировании 2D-характеристики или 3D-характеристики в режиме сечения на 

диаграмме отображаются также старые данные.  

Применение отредактированных данных характеристики происходит по щелчку на кнопку 

 панели инструментов, или нажатию сочетания клавиш Ctrl+S. Если включен режим 

автоматического применения значений (кнопка ), то данные в ЭБУ изменяются сразу 

после редактирования значений в таблице. 
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Контекстное меню диаграммы имеет пункты: 

 Show topic – выделить редактируемую характеристику (или ось) в таблице 

параметров; 

 Autoscale – автоматический масштаб по шкале Y. Если пункт не выбран, то 

границы отображения определяются минимальным и максимальным значением для 

данного параметра; 

 Uniform Grid – отображение характеристики на диаграмме с визуально 

равномерным шагом значений осей; Если пункт не выбран, то шаг значений осей на 

экране отражает реальные масштабы; 

 Mirror Axis X – развернуть направление оси X. Если пункт не выбран, то 

направление оси – "слева направо". При развороте оси данные в таблице значений 

также разворачиваются. Это необходимо для удобства сопоставления вида таблицы и 

диаграммы; 

 Mirror Axis Z – развернуть направление оси Z. Если пункт не выбран, то 

направление оси – "от нас". При развороте оси данные в таблице значений также 

разворачиваются. Это необходимо для удобства сопоставления вида таблицы и 

диаграммы; 

 Interpolate by Axis Data – интерполировать с учетом значений осей. Если 

пункт выбран, то интерполяция производится с учетом значений осей характеристики. 

Иначе для интерполяции считается, что шаг значений оси равномерный; 

 Show Axis – показать ось (только при отображении характеристики). Перейти к 

просмотру/редактированию осей данной характеристики. Меню содержит 1 или 2 

дочерних элемента (по количеству осей); 

 Select Axis Z – выбрать ось Z для характеристики. Некоторые характеристики 

поддерживают возможность выбора оси, которая будет использоваться для расчета. 

 

Список доступных осей отображается во вложенном меню; 



Руководство пользователя SPTuner 

 

 14 

 Relative Charts… - показать связанные характеристики (только при 

отображении оси). Перейти к просмотру/редактированию характеристик, 

использующих данную ось; 

 Export to CTE file… - экспорт значений характеристики в файл CTE; 

 Import from CTE file… - импорт значений характеристики из файла CTE; 

 Advanced CTE Import… - импорт значений характеристики из файла CTE с 

дополнительными возможностями. Функция позволяет выбрать любую 

характеристику из CTE-файла. При импорте характеристики значения осей не 

загружаются из данных характеристики CTE-файла, но используются для 

интерполяции; 

 Settings… - вызов окна настроек отображения характеристики. 

На диаграмме помимо данных отображаются 2 вида точек: черная точка отображает 

текущую выделенную точку (точки) в таблице; голубая точка отображает текущую 

рабочую точку, если для данной характеристики такая возможность имеется.  

В таблице также отображается рабочая точка. Причем, геометрически значения оси 

находятся в середине ячейки таблицы. Например, на рисунке ниже показан пример 

отображения рабочей точки при частоте вращения 990 об/мин (т.е. совпадает с одним из 

значений оси). 

 

При помощи кнопок   осуществляется перемещение по ранее просмотренным 

характеристикам и осям. 

3.8. Редактирование осей характеристик 

Редактирование осей характеристик производится аналогично редактированию 

2D-характеристик. Оси находятся в конце таблицы параметров в группе Axes. 

Для отображения окна связанных характеристик выбранной оси необходимо выбрать 

пункт Show related charts контекстного меню. Появится окно со списком 

наименований характеристик. Выбор элемента списка приведет к показу окна 

соответствующей характеристики. При этом окно связанных характеристик остается на 

экране. Для возврата к редактированию оси необходимо щелкнуть по её наименованию в 

самом верху окна (например, по надписи Rpm на рисунке ниже). 
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При применении новых значений данных оси появляется диалог подтверждения 

интерполяции данных связанных характеристик. В списке находятся наименования всех 

характеристик, с которыми связана отредактированная ось. 

 

После нажатия OK интерполяция данных будет выполнена для характеристик, отмеченных 

в списке. При работе в онлайн-режиме данные характеристик принимаются из ЭБУ, 

модифицируются и отправляются обратно. По окончанию процесса выводится сообщение 

подтверждения. 

3.9. Работа с осциллографом 

В ПО SPTuner имеется возможность записи осциллограмм работы ЭБУ. В качестве 

каналов осциллографа может быть выбран любой параметр-переменная. Максимальное 

количество каналов – 60. Реально доступное количество каналов зависит от пропускной 

способности интерфейса связи и частоты опроса осциллографа. Так, например, если CAN 

сеть состоит только из ЭБУ и DiaLink, то на скорости 1000 кбит/с возможна запись 20 
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каналов с разрешением 1 мс. Изменение состава записываемых каналов доступно только 

при остановленном осциллографе. Для добавления окна осциллографа необходимо 

выбрать пункт меню View->Scope. 

Окно осциллографа может содержать несколько полей для отображения кривых. Для 

каждого поля задается диапазон по оси ординат, цвет фона, сетки и т.д. Высоту каждого 

поля можно изменить с помощью мыши, перетаскивая нижнюю границу. Поле может 

содержать несколько кривых (каналов), каждая из которых имеет свои настройки 

толщины линии, цвета линии и масштаба. Добавление новых полей производится 

выбором меню Scope->Add Field, или нажатие клавиши Ins в окне осциллографа. 

Для добавления новых каналов в поле осциллографа необходимо при помощи мыши 

перетащить выделенные параметры из таблицы параметров (или из рабочего набора) в 

поле осциллографа. 

Выделение полей осциллографа осуществляется нажатием ЛКМ в области шкалы с 

зажатой клавишей Shift. Выделенные поля имеют желтый цвет.  Пример выделенного 

поля с кривыми Gbc и GbcBase представлен на рисунке ниже. 

 

Состав главного меню осциллографа (Scope): 

Start начать запись осциллограммы 

Stop остановить запись осциллограммы 

Resolution шаг опроса. Меню отображает список доступных 

разрешений в секундах. 

 

Zoom масштаб отображения данных по шкале времени при записи 

Save… сохранить осциллограмму на диск в формате CSV 

Save by Cursors… сохранить фрагмент текущей осциллограммы, 

ограниченный курсорами 

Open открыть осциллограмму с диска 

Copy to Clipboard копировать графическое содержимое текущего окна 
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осциллографа в буфер обмена 

Add Field добавить поле в текущее окно 

Move Selected Up переместить выделенные поля вверх 

Move Selected Down переместить выделенные поля вниз 

Delete Selected удалить выделенные поля 

Combine Selected объединить выделенные поля в одно 

Для доступа к функциям осциллографа помимо главного меню используется контекстное 

меню, вызываемое щелчком ПКМ в области шкалы графика.  

Контекстное меню поля осциллографа содержит следующие пункты: 

Меню поля 

Field Settings… Настройки поля осциллографа (диапазон, цвета элементов) 

Paste Curve Вставить кривую. Данному действую должен 

предшествовать выбор пункта Cut в меню кривой 

Hide cursors Скрыть все курсоры 

Hide all curves Скрыть все кривые 

Show all curves Показать все кривые 

Шкала времени (для всех полей текущего окна) 

Axis X view aсtual Масштаб 1:1 (на один пиксель экрана одно измерение) 

Axis X view all Масштаб устанавливается таким, чтобы были видны все 

данные (вся записанная осциллограмма отображается в 

осциллографе) 

Шкала значений (для одного поля) 

Axis Y view all Автоматический масштаб по всем значениям видимого 

участка времени 

Axis Y limits preset Выбор предустановленных диапазонов 

 

При щелчке ПКМ по наименованию одного из каналов в контекстное меню осциллографа 

появляется контекстное меню канала, содержащее следующие элементы: 

Show topic Показать группу в таблице параметров, которая содержит 

данный параметр 

Gain Выбрать коэффициент усиления для отображения в одном 

поле нескольких каналов с различным диапазоном значений 

Visible Показать/скрыть кривую. Также осуществляется щелчком 

ЛКМ с зажатой клавишей Ctrl по наименованию канала 

Mask… Маска канала (для битовых переменных) 

Color… Показать диалог выбора цвета кривой 

Width Выбрать толщину линии 

Delete Удалить кривую. Также осуществляется щелчком ЛКМ с 



Руководство пользователя SPTuner 

 

 18 

зажатой клавишей Alt по наименованию канала 

Cut Вырезать кривую для переноса в другое поле 

В примере на рисунке ниже показано контекстное меню поля осциллографа, содержащее 

меню канала "Thr". 

 

Коэффициент усиления канала отображается рядом с его наименованием. 

 

Полученная в результате указанных выше настроек (период опроса и масштаб) цена 

деления осциллографа отображается на главной панели состояния.  

 

Для начала записи осциллограммы необходимо выбрать пункт меню Scope->Start. 

Останов записи произойдет при выборе пункта меню Scope->Stop, закрытии 

соединения, ошибке связи, закрытии программы. 

Запись производится в кольцевой буфер, содержащий 2∙10
5
 точек, что при периоде опроса 

10 мс соответствует примерно 32 минутам длительности записи. Текущий процент 

заполнения буфера отображается на панели состояния (раздел Scope buffer). 

В процессе записи осциллограммы под наименованиями кривых отображаются текущие 

значения записываемых параметров. 
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После останова записи пользователь может просматривать осциллограмму, изменяя 

масштаб отображения с помощью команд контекстного меню.  

Кроме того, доступно масштабирование по шкале времени при помощи мыши путем 

выделения интересующего участка. 

Для получения точных значений величин записанных каналов в нужный момент времени, 

а также для измерения временных интервалов имеется возможность установки двух 

курсоров (красный и синий) в поле осциллограммы. При этом рядом с наименованиями 

каналов выводятся значения "под курсорами".  

 

 

Время красного курсора (в секундах от начала записи) и временной интервал (расстояние) 

между курсорами выводится на главную панель состояния: 

 

При установке красного курсора (при наличии в окне осциллограммы необходимых 

каналов) в окне характеристики отображается рабочая точка, соответствующая времени 

курсора. Данная функция также доступна в оффлайн-режиме после открытии файла 

осциллограммы. 

При записи следующей осциллограммы курсоры удаляются. 

Курсоры устанавливаются щелчком левой (красный) и правой (синий) кнопки мыши. 

После установки курсоры можно двигать по полю графика. Убираются курсоры выбором 

пункта Hide cursors контекстного меню графика. 

3.10. Просмотр сохраненных осциллограмм 

Открыть ранее сохраненную осциллограмму можно выбрав пункт Scope->Open в 

главном меню. Открыть осциллограмму можно в онлайн-режиме или в оффлайн-режиме 

(после открытия файла параметров). После выбора имени файла осциллограммы  появится 

диалоговое окно, позволяющее выбрать способ открытия файла: 
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Варианты способов открытия: 

Load data in existing scopes Данные осциллограммы загружаются только 

в существующие поля осциллографа. Если 

осциллограмма содержит каналы, не 

задействованные в текущей рабочей области, 

то они игнорируются. 

Load data in new page При открытии создается новая вкладка 

OscFromFile, в которой появляется окно 

осциллографа, содержащее все каналы из 

открываемого файла. 

Load unused curves data in new 

page 

При открытии создается новая вкладка 

OscFromFile, в которой появляется окно 

осциллографа, содержащее каналы из 

открываемого файла, не используемые в 

рабочей области программы. 

Если файл осциллограммы не содержит данных для некоторых каналов, используемых в 

рабочей области программы, то такие каналы после открытия осциллограммы становятся 

неактивными и не отображают кривых.  

После открытия файла осциллограммы имя файла отображается в заголовке окна 

осциллографа. 

3.11. Экспресс-панель 

Экспресс-панель предназначена для постоянного контроля за важными параметрами ЭБУ. 

Пользователь может конфигурировать внешний вид этой панели и набор параметров, 

отображаемых ею. 

 

Добавление параметров в экспресс панель осуществляется перетаскиванием из таблицы 

параметров или из рабочего набора. Дальнейшая настройка внешнего вида производится 

из окна настройки экспресс-панели, где пользователь может задать количество колонок, 

цвет фона, шрифт наименований параметров и шрифт значений параметров. Окно 

настройки открывается по двойному щелчку в окне экспресс-панели. 
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Данное окно дает возможность настроить порядок отображения параметров и удалить 

ненужные параметры из списка. 

3.12. Стрелочные приборы 

Виртуальные стрелочные приборы предназначены для отображения значений параметров-

переменных.  

 

Для назначения параметра стрелочному прибору необходимо перетащить его из таблицы 

параметров или из рабочего набора параметров. После этого в заголовке окна появится 

наименование параметра, а на шкале прибора будут отображены единицы измерения. 

 

Окно настроек стрелочного прибора вызывается из контекстного меню и позволяет 

сконфигурировать внешний вид прибора. 
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3.13. Работа с флагами 

Двойной щелчок (или нажатие клавиши Enter) на параметре-массиве флагов приводит к 

открытию отдельного окна со списком именованных флагов. Наименование параметра 

отображается в заголовке окна. 

 

Если параметр допускает изменение значений, то флаг инвертируется по щелчку ЛКМ на 

чекбоксе. 

Флаги из массива только для чтения можно перетаскивать в поле осциллографа. 

Наименование канала осциллографа будет состоять из наименования параметра и 

наименования флага, например F1^Sync crank (параметр F1, флаг Sync crank): 

 

 

3.14. Ручной корректор значений 

Для интерактивной подстройки значений параметров-настроек предназначено окно 

корректора. Данную функцию можно использовать при тестировании механизмов 

(например, РХХ) или изменения коэффициентов регуляторов и пр. 

Вызов окна осуществляется выбором пункта меню View->Knob.  
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В поле окна необходимо перетащить параметр, подлежащий подстройке. После этого 

наименование параметра появляется в заголовке окна, и отображаются минимальное и 

максимальное значения. 

 

Минимальное и максимально значение можно изменить в окне настройки (пункт 

Settings контекстного меню). Подстройка значения осуществляется путем 

перемещения движка корректора или клавишами Left/Right. Программируемое 

изменение значения осуществляется клавишами PgDn/PgUp. 

4. Обновление микропрограммы 

Обновление микропрограммы осуществляется при установленном соединении выбором 

пункта меню Tools->Update firmware. Затем необходимо выбрать файл 

микропрограммы (расширение "fwu"), после чего сразу начинается процесс загрузки. Если 

двигатель запущен, то появится сообщение об ошибке "Can't update firmware!". 

Степень завершенности процесса отображается полосой прогресса. По окончанию 

загрузки необходимо выполнить перезапуск ЭБУ и при необходимости установить 

соединение заново. 

При возникновении ошибок загрузки микропрограммы процесс прерывается и 

формируется сообщение с кодом ошибки. 

! 
При обновлении микропрограммы необходимо обеспечить бесперебойное 

питание ЭБУ и ПК. Потеря питания в процессе программирования может 

привести к невозможности работы микропрограммы. Восстановление 

работоспособности производится только в SMS-Soft. 

В некоторых ЭСУД (особенно при использовании нестандартных комбинаций приборов 

или подключенных диагностических устройствах) обновление микропрограммы может 

быть неуспешным. Рекомендуется в таких случаях оставить на CAN-шине только 2 

абонента - ЭБУ и адаптер DiaLink. 

После перезапуска ЭБУ выполняется процедура актуализации значений параметров, в 

результате которой значения параметров, поддерживаемых новой версией 

микропрограммы сохраняются, а вновь появившиеся параметры инициализируются 

значениями по умолчанию. 

! 
Настоятельно рекомендуется сохранить значения всех параметров в файл 

(см. п.3.2) перед обновлением. 

После обновления, связанного с переходом на другой задающий диск 

необходимо загрузить значения всех параметров из сохраненного файла в 

ЭБУ и выполнить дополнительный перезапуск. Затем необходимо 

выполнить проверку всех параметров, связанных с синхронизацией и фазой 

работы двигателя. 
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5. Взаимодействие с контроллером ШДК 

SPTuner позволяет получать информацию о составе смеси по цифровому интерфейсу с 

контроллером ШДК. Поддерживается протокол контроллеров ф. Innovate. Контроллер 

ШДК подключается к ПК по интерфейсу RS-232 или USB. В системе должен быть 

установлен драйвер, входящий в состав ПО LogWorks. ПО можно загрузить на сайте 

производителя Innovate Motorsports. 

Для настройки соединения необходимо выбрать пункт меню Tools->Lambda Sensor 

Settings…  

    

В окне настойки выбирается номер порта для подключения. В поле Status отображается 

текущее состояние соединения или устройства. 

SPTuner автоматически устанавливает связь с контроллером ШДК после соединения с 

ЭБУ. 

Особенности использования ALF по цифровому интерфейсу см. в Руководстве на 

SPTronic. 

  

http://www.innovatemotorsports.com/
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6. Горячие клавиши 

Горячие клавиши основного окна: 

Клавиша Функция 

F2 Сохранение файла осциллограммы 

F5 Установка соединения с ЭБУ 

F6 Окончание сеанса связи с ЭБУ 

F7 Начать запись осциллограммы 

F8 Остановить запись осциллограммы 

F9 Развернуть текущее окно/восстановить размер текущего окна 

F10 Перейти на следующую вкладку 

Ctrl+F10 Перейти на предыдущую вкладку 

F11 Показать таблицу параметров и выделить в ней текущий параметр 

F12 Показать таблицу параметров 

Горячие клавиши окна параметров: 

Клавиша Функция 

Ctrl+A Выделение всех параметров, выводимых в таблицу 

Ctrl+F Активация фильтра наименований параметров 

Ctrl+C Скопировать содержимое таблицы параметров в буфер обмена 

Горячие клавиши окна характеристик: 

Клавиша Функция 

"+"(=) на 

основной 

клавиатуре 

Увеличение значения выделенных ячеек таблицы на величину из 

панели инструментов (строка ввода) 

"-"(_) 
Уменьшение значения выделенных ячеек на величину из панели 

инструментов (строка ввода) 

Ctrl+"+" Увеличение значения в строке ввода на панели инструментов 

Ctrl+"-" Уменьшение значения в строке ввода на панели инструментов 

PgUp 
Увеличение значения выделенных ячеек на величину 10-кратного 

значения квантования 

PgDn 
Уменьшение значения выделенных ячеек на величину 10-кратного 

значения квантования 

Shift+PgUp Увеличение значения выделенных ячеек на величину квантования 

Shift+PgDn Уменьшение значения выделенных ячеек на величину квантования 

Ctrl+A Выделение всех ячеек значений характеристики 

Ctrl+C 
Скопировать содержимое таблицы значений характеристики в буфер 

обмена 

Ctrl+V 
Вставка содержимого буфера обмена в таблицу значений 

характеристики 

Ctrl+S 
Применение изменений данных характеристики (пересылка данных в 

ЭБУ) 

Ctrl+Z 
Возврат значений в таблице на текущие значения, находящиеся в ОЗУ 

ЭБУ 

F11 Показать группу, содержащую данный параметр в таблице параметров 

F12 Показать таблицу параметров 

Alt+"←" Переход к предыдущей характеристике/оси в списке недавно открытых 

Alt+"→" Переход к следующей характеристике/оси в списке недавно открытых 
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